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DREAMWEAVER CS5  
PART 2 
An Introduction to CSS 

Presented by Jacques Walker 

Course Objective 

¨  Create a HTML webpage that incorporates Web 
2.0 Standards 

¨  Define Web 2.0 
¨  Define “divs” 
¨  Define CSS 

What is Web 2.0? 

¨  Guidelines for website production 
¤ Rich user experience, user participation, dynamic 

content, metadata, web standards and scalability 

¨  Incorporates the use of 
¤ Divs 
¤ CSS 
¤ Multimedia 
¤ Javascript 
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What is a div 

¨  Used for layout and 
placement 

¨  What about tables? 
¤ Advantages 
¤ Disadvantages 

¨  General Syntax 
•  Just like HTML 
•  <open>Content</close> 
•  Example: <div class=Main_Content> Content </div> 

What’s really there 

<div class="Main_Content"> 

 

         <div class="Header"> 

         </div> 
 

         <div class=“img_header”> 

         <p>Page Title Goes Here</p> 

         </div> 
 

         <div class="Navigation"> 

           <p align="center">Navigation Items</p> 

         </div> 

          

         <div class="Page_Content"> 

           <p>Page Content</p> 

         </div> 

          

         <div class="Footer"> 

         <p>Footer Content</p> 

         </div> 
 

</div> 

So what’s this CSS thing 

¨  Cascading Style Sheet 
¨  Provides formatting of elements for the entire site 

¤ Links, fonts, headers, etc. 
¤ Change one and you’ve got them all 

¨  Not a perfect science 
¤ Trial and error 
¤ Flexible   
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A closer look  

¨  General Syntax 
¤  Inline Styling 

n  <p style=“color:red; border:dotted”>Content</p> 

¤ CSS – Classes and Elements 
n  .Main_Content p{ 

    color: red; 
    border: dotted; 
} 

n 1st: Define the area 
n 2nd: List your changes 

Create Site in Dreamweaver 

¨  Go to Shared Folder on Desktop 
¨  Copy Exercise Site to your Desktop 
¨  Open Dreamweaver 

¤ Create a new site 

Setting Page Backgrounds 

¨  Create a new page 
¤ Select File>New>Blank Page>HTML 

¨  Setting the Page Background 
¤ Click the Page Properties button 

 
¤ Set the Background Color to Grey 

n #CCC 

¤ Click Apply and OK 



Dreamweaver	
  CS	
  4:	
  	
  An	
  Introduc5on	
  to	
  CSS	
  

4	
  

Beginning the Process 
¨  Inserting a Div 

¤  Select Insert>Layout Object>Div Tag 
¤ Click the New CSS Rule Button 

¨  Creating a New Stylesheet 
¤  Enter the Following into the Dialog box>Click OK>Save 

Creating Main_Content div styles 

¨  Creating a Class Style 
¤ Using the dialog box that appears add the information 

shown in Appendix A, .Main_Content 
¤ Click Apply>OK>OK 

¨  Creating an Element Style 
¤ Click the stylesheet button 
¤ Add the Information from Appendix A, .Main_Content p 

n  .Main_Content indicates the Div 
n p indicates the element you are modifying in the Div (i.e. the 

paragraph tag) 

Inserting the Header 

¨  Highlight and Delete the Placeholder text. 
¨  Insert>Layout Object>Div Tag>New CSS Rule 

¤ Sector Type: Class 
¤ Sector Name: Header 

n See Appendix A, .Header for Properties 
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Inserting the Image Header 

¨  Below the Header Div add a new Div 
¤ Class Name: img_header 
¤ Properties: .img_header Section of Appendix 

¨  Add a paragraph element style 
¤ Add the Information from Appendix A, .img_header p 

n  .img_header indicates the Div 
n p indicates the element you are modifying in the Div (i.e. the 

paragraph tag) 

Creating Navigation 

¨  Below the img_header Div add a new Div 
¤ Class Name: Navigation 
¤ Properties: .Navigation Section of Appendix 

¨  Important Note: 
¤ Divs expand based on the text inside them, thus a 

height must be added for background images  

Ummm, What is that??? 
It’s a Firebug 

O.o? 

Creating the Content Well 

¨  Below the Navigation Div add a Page_Content Div 
¤ Class Name: Page_Content 
¤ Properties: .Page_Content 

¨  Note: Dreamweaver doesn’t know it all, sometime 
you have to take control. 
¤  (i.e. min-height: 240px) 
¤ W3schools: www.w3schools.com 
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Creating the Footer & Finishing Up 

¨  Below the Page_Content Div add a new div 
¤ Class:  Footer 
¤ Properties: .Footer 

¨  Centering your page 
¤ Prebuilt centering doesn’t exist 
¤ An ingenuitive solution does exist. 

Closing Remarks 

¨  Firebug 
¤  A Firefox extension for CSS Manipulation 

¨  W3 Schools 
¤  CSS Reference Website 
¤  http://www.w3schools.com 

¨  University Relations Branding 
¤  Color Palette 

n  http://www.unirel.vt.edu/web/guidelines/web-palette/index.html 

¤  Web Guidelines 
n  http://www.unirel.vt.edu/web/guidelines/index.html 

¤  Branding Images 
n  http://www.branding.unirel.vt.edu/web_guidelines.php 

Need Help/More Info 

¨  Dreamweaver Part 3 Course Available 
¨  Resources 

¤ Lynda.vt.edu 
n  https://www.fdi.vt.edu/online-resources/support_skills/essential-skills.html 

n  Dreamweaver CS6 Essential Training 

n  CSS Fundamentals 

n  CSS: Core Concepts 

¤  InnovationSpace 
n  1140 Torgersen Hall 

Questions?? 
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Type	
  Fields:	
  

Font-­‐Family:	
  Specifies	
  the	
  font	
  used.	
  
Note:	
  Three	
  are	
  listed;	
  The	
  OS	
  determines	
  the	
  
one	
  used.	
  
Font	
  Size:	
  Specifies	
  the	
  size	
  of	
  the	
  font	
  used.	
  
Font-­‐weight:	
  Specifies	
  the	
  level	
  of	
  bold.	
  
Font-­‐style:	
  Turns	
  Italics	
  on	
  or	
  off.	
  
Font-­‐variant:	
  Turns	
  small	
  caps	
  on	
  or	
  off.	
  
Line-­‐height:	
  	
  Determines	
  the	
  amount	
  of	
  
spacing	
  between	
  the	
  lines	
  of	
  text.	
  
Text-­‐transform:	
  Determines	
  the	
  case	
  type	
  of	
  
the	
  font	
  (i.e.	
  Upper	
  case).	
  
Ext-­‐decoration:	
  Adds	
  additional	
  styling	
  for	
  

fonts.	
  
Color:	
  Specifies	
  the	
  color	
  of	
  the	
  font.	
  
	
  
Background	
  Fields:	
  

Background-­‐color:	
  Determines	
  the	
  color	
  of	
  
the	
  background.	
  
Background-­‐images:	
  Inserts	
  an	
  image	
  into	
  
the	
  background	
  of	
  the	
  area.	
  
Background-­‐repeats:	
  Repeats	
  an	
  image	
  
across	
  the	
  x	
  or	
  y	
  axis.	
  
Background-­‐attachment:	
  Determines	
  if	
  the	
  
image	
  moves	
  along	
  with	
  scrolling	
  or	
  stays	
  
fixed	
  in	
  a	
  position.	
  
Background-­‐position:	
  X	
  and	
  Y	
  coordinate	
  of	
  
the	
  background	
  image.	
  
	
  

	
  
Block	
  Fields:	
  	
  

Word-­‐spacing:	
  Determines	
  the	
  spacing	
  
between	
  words.	
  
Letter-­‐spacing:	
  Determines	
  the	
  spacing	
  
between	
  letters.	
  
Vertical-­‐align:	
  Determines	
  the	
  vertical	
  
alignment	
  of	
  the	
  item	
  (i.e.	
  top,	
  middle,	
  etc).	
  
Text-­‐align:	
  	
  Determines	
  the	
  alignment	
  of	
  text	
  
(i.e.	
  left,	
  center,	
  etc).	
  
Text-­‐indent:	
  	
  Specifies	
  the	
  amount	
  to	
  which	
  
text	
  is	
  indented.	
  



Box	
  Fields:	
  
Width:	
  Specifies	
  the	
  width	
  of	
  the	
  element.	
  
Height:	
  Specifies	
  the	
  height	
  of	
  the	
  element.	
  
Float:	
  Specifies	
  the	
  position	
  in	
  relation	
  of	
  the	
  
element	
  to	
  other	
  elements.	
  
Clear:	
  Specifies	
  if	
  additional	
  elements	
  are	
  
allowed	
  around	
  the	
  element.	
  
Padding:	
  Specifies	
  the	
  amount	
  of	
  spacing	
  
inside	
  the	
  element.	
  
Margin:	
  Specifies	
  the	
  amount	
  of	
  spacing	
  
outside	
  of	
  the	
  element.	
  
	
  
	
  

	
  
Border	
  Fields:	
  

Styling:	
  Specifies	
  the	
  styling	
  of	
  the	
  border	
  
(i.e.	
  Dotted,	
  Dashed).	
  
Width:	
  Specifies	
  the	
  width	
  of	
  the	
  border.	
  
Color:	
  Specifies	
  the	
  color	
  of	
  the	
  border.	
  
	
  
	
  
	
  
	
  
	
  
	
  
	
  
	
  

	
  
List	
  Fields:	
  

List-­‐style-­‐type:	
  Specifies	
  the	
  shape	
  of	
  the	
  list	
  
bullet	
  (i.e.	
  circle,	
  square).	
  
List-­‐style-­‐image:	
  Specifies	
  an	
  image	
  to	
  be	
  
used	
  in	
  place	
  of	
  the	
  bullets	
  of	
  the	
  list.	
  
List-­‐style-­‐Position:	
  Specifies	
  if	
  the	
  bullets	
  
should	
  appear	
  in	
  line	
  with	
  text	
  or	
  indented.	
  	
  
	
  
	
  
	
  
	
  
	
  
	
  

	
  
	
  
	
  



Positioning	
  Fields:	
  
Position:	
  Specifies	
  the	
  position	
  type	
  of	
  the	
  
element	
  (i.e.	
  absolute,	
  relative).	
  
Visibility:	
  Specifies	
  if	
  the	
  item	
  is	
  visible	
  or	
  
not.	
  
Width:	
  Specifies	
  the	
  width	
  of	
  the	
  element.	
  
Height:	
  Specifies	
  the	
  height	
  of	
  the	
  element.	
  
Z-­‐Index:	
  Specifies	
  the	
  position	
  of	
  an	
  item	
  on	
  
the	
  z-­‐axis.	
  
Overflow:	
  Determines	
  what	
  happens	
  to	
  
items	
  that	
  exceed	
  the	
  content	
  area.	
  
Placement:	
  Specifies	
  the	
  placement	
  of	
  the	
  
item	
  on	
  the	
  page.	
  
	
  

Clip:	
  Specifies	
  what	
  happens	
  to	
  an	
  image	
  larger	
  than	
  the	
  content	
  area.	
  
	
  
Extensions	
  Fields:	
  

Page-­‐break-­‐before:	
  Specifies	
  if	
  page	
  breaks	
  
occur	
  before	
  the	
  item.	
  
Page-­‐break-­‐after:	
  Specifies	
  if	
  page	
  breaks	
  
occur	
  after	
  the	
  item.	
  
Cursor:	
  Modifies	
  the	
  look	
  of	
  the	
  mouse	
  
pointer.	
  
Filter:	
  Specifies	
  additional	
  formatting	
  and	
  
visual	
  displays	
  for	
  images	
  and	
  other	
  
elements.	
  
For	
  more	
  Information:	
  
http://www.webdesign.org/html-­‐and-­‐
css/tutorials/css-­‐filters-­‐ie-­‐only.10015.html	
  
	
  



  1  @charset "utf-8";
  2  .Main_Content {
  3      /*----Type----*/
  4      font-family: Verdana, Geneva, sans-serif;
  5      /*----Background----*/
  6      background-color: #FFF;
  7      /*----Block----*/
  8      text-align: left;
  9      /*----Box----*/
 10      padding: 5px;
 11      width: 974px;
 12      margin-top: 0;
 13      margin-right: 0px;
 14      margin-bottom: 0;
 15      /*----Border----*/
 16      border-top-width: 2px;
 17      border-right-width: 2px;
 18      border-bottom-width: 2px;
 19      border-left-width: 2px;
 20      border-top-color: #999;
 21      border-right-color: #999;
 22      border-bottom-color: #999;
 23      border-left-color: #999;
 24      /*----Positioning----*/
 25      position: absolute;
 26      /*----Styling to Center Main_Content----*/
 27      margin-left: -487px;
 28      left: 50%;
 29  }
 30  .Main_Content p{
 31      /*----Box----*/
 32      margin-top: 0px;
 33      margin-right: 4px;
 34      margin-bottom: 0px;
 35      margin-left: 4px;
 36      padding-top: 0px;
 37      padding-right: 1px;
 38      padding-bottom: 0px;
 39      padding-left: 1px;
 40  
 41  }
 42  .Header {
 43      /*----Background----*/
 44      background-attachment: scroll;
 45      background-image: url(Images/sp_header.jpg);
 46      background-repeat: no-repeat;
 47      background-position: center center;
 48      /*----Box----*/
 49      width: 974px;
 50      height: 82px;
 51      margin-bottom: 3px;
 52  }
 53  .img_header {
 54      font-family: "Times New Roman", Times, serif;
 55      font-size: 25px;
 56      color: #FFF;
 57      background-color: #999;
 58      background-image: url(Images/img_header.jpg);
 59      background-repeat: no-repeat;
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 60      text-align: right;
 61      height: 37px;
 62      width: 969px;
 63      padding: 123px 5px 0 0;
 64      position: relative;
 65      margin: 0 0 3px;
 66  }
 67  .img_header p{
 68      padding: 0;
 69      margin: 0;
 70  }
 71  .Navigation {
 72      /*------Type----*/
 73      font-family: Arial, Helvetica, sans-serif;
 74      font-size: 1em;
 75      font-style: normal;
 76      line-height: 1.71em;
 77      color: #FFF;
 78      /*-----Background----*/
 79      background-image: url(Images/nav_bar.jpg);
 80      background-repeat: repeat-x;
 81      /*----Box---*/
 82      height: 45px; /*--Determined via firebug--*/
 83      margin-top: 1px;
 84      margin-right: 0px;
 85      margin-bottom: 0px;
 86      margin-left: 0px;
 87      padding-top: 8px; /*--Determined via firebug--*/
 88      padding-right: 1px;
 89      padding-bottom: 0px;
 90      padding-left: 1px;
 91      /*----List---*/
 92      list-style-type: none;
 93  }
 94  .Page_Content {
 95      /*---Type---*/
 96      font-family: Arial, Helvetica, sans-serif;
 97      font-size: 14px;
 98      font-style: normal;
 99      color: #000;
100      /*---Background---*/
101      background-color: #f4f3e6;
102      background-repeat: repeat-y;
103      /*----Box--*/    
104      margin-top: 0px;
105      margin-right: 1px;
106      margin-bottom: 0px;
107      margin-left: 1px;
108      padding-top: 0px;
109      padding-right: 1px;
110      padding-bottom: 0px;
111      padding-left: 1px;
112      /*---Positioning---*/
113      width: 971px;
114      position: relative;
115      /*---Extra Stuff--*/
116      min-height:330px;
117      background-image: url(Images/content.jpg);
118      overflow:auto;
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119      }
120  .Footer {
121      /*---Type---*/
122      font-family: Verdana, Geneva, sans-serif;
123      font-size: 12px;
124      color: #FFF;
125      /*--Background--*/
126      background-image: url(Images/footer.jpg);
127      background-repeat: repeat-x;
128      /*---Box---*/
129      padding-top: 67px;/*--Determined via firebug--*/
130      padding-right: 1px;
131      padding-bottom: 3px;
132      padding-left: 3px;
133      height: 21px;/*--Determined via firebug--*/
134  }
135  .Left_Content {
136      font-family: Arial, Helvetica, sans-serif;
137      font-size: 14px;
138      color: #000;
139      padding: 5px;
140      width: 701px;
141      float: left;
142      height:auto;
143      margin:0px;
144      position:relative;
145  }
146  .Right_Bar {
147      font-family: Arial, Helvetica, sans-serif;
148      font-size: 14px;
149      color: #000;
150      padding: 5px;
151      float: left;
152      width: 235px;
153      margin-top: 0px;
154      margin-right: 5px;
155      margin-bottom: 0px;
156      margin-left: 10px;
157      position: relative;
158  }
159  
160  
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